Diablo 3 lag/slowing down

Home Forums Specific issues with VirtualGamepad Diablo 3 lag/slowing down

This topic contains 4 replies, has 2 voices, and was last updated by  fire 2 years, 4 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #68246

    fire
    Participant

    I’m very much liked virtual gamepad for tablet gaming
    So after some hard time trying to get diablo 3 to run smoothly on my surface pro 3 without success ( i have tried all the lowest setting, even 800×600 resolution just to make it smooth).. at last i found the source of the problem is virtual gamepad. If I didnt use virtual gamepad, the game actually run smoothly, but when I turn on virtual gamepad, it automatically start to lag/slowing down that it makes it unplayable (not worthed to play with the lag)

    Any setting or help for this problem?
    I uswd windows 10 and yes I used windowed mode

    #68309

    fire
    Participant

    after trying more..
    dont know why, now ALL games that I tried lagging
    I have tried grim dawn, and dolphin emulator.
    and those having problem with virtual gamepad on. they would lag so much, fps dropped, sounds stuttered… but when I off virtual gamepad, they all would play smoothly, fps going up, sounds smooth.

    I really2 liked using virtual gamepad on my previous tablet (which I sold last year), and now after trying it on new tablet, it’s not working good at all.. so sad.

    #68314

    PalmTime
    Keymaster

    Hi,

    I answered you the other evening by email with the following :

    There is a setting in VirtualGamepad to lower it’s refresh rate. There is also a touchpad mode that is a little bit more demanding.

    Unfortunately, to some degree, VG does use some resources and lower the frame per second of demanding game. I hope you get the result you were looking for.

    Let me know how it turned out.

    Thanks for your feedback. Have you tried increasing the refresh delay option ?

    #68315

    fire
    Participant

    hi,
    I didnt get your email.

    could u tell me where is the setting ? pls just reply here to make sure I could read it.

    I didnt see any setting on my virtual gamepad other than to turn it on/off, save/load gamepad, edit gamepad,and change how the mouse worked. and yes, I did use touchpad mode as I like it very much. infact it’s the reason why I like virtual gamepad cause it emulates touchpad so good, that I couldnt replicate it with another virtual (*cough* gest… *cough*)
    I might miss something. pls tell me where is the setting to lower its refresh rate and where to increase the refresh delay option ?

    • This reply was modified 2 years, 4 months ago by  fire.
    #68317

    fire
    Participant

    sorry
    after trying again
    it turns out that what i used is touchscreen cursor mode not touchpad mode

    and i found the increase refresh delay option and after increase it to 10, dolphin runs smoothly with virtual gamepad
    too bad for some reason, diablo 3 and grim dawn runs slower and more laggy on windowed mode even before turning virtual gamepad on. so i have to play it on fullscreen so i couldnt use virtual gamepad
    hope u can make it support fullscreen someday

    thx for the help

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.