Virtual Mouse stopped to work

Home Forums Specific issues with VirtualGamepad Virtual Mouse stopped to work

This topic contains 5 replies, has 3 voices, and was last updated by  PalmTime 4 years, 3 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #26713

    vodyanoy38
    Participant

    Hi!First of all,I want to thank the developer for this great program!I’ve bought a tablet for games only,and VirtualGamepad works good with my favourite games,I even don’t want to buy a real gamepad anymore.
    But after a few days of using it,I got a problem:
    In mouse-based games,such as Fallout3,Fallout:New Vegas,Stalker:Shadow of Chernobyl,the virtual mouse stopped working.When the game menu appears(start game,load,options,etc),the in-game cursor stays unmovable in the centre of the screen,while you can move virtual cursor independently from it,above the game window.
    Sometimes vice versa,the virtual mouse pointer moves below the game window.When I connect the real mouse,and start the game,virtual mouse begins to work,it continues to work even if I disconnect the real mouse.But once I exit from the game to Windows,I can’t start the game again without a real mouse connected.
    I’ve already played these games with VirtualGamepad(both Demo and Donationware Beta),so these games are compatible with it.
    This problem happens for the second time,in the first time I just played a little with a real mouse,and the problem disapeared,as sudden as it appeared.But now nothing helps.Even complete re-installing windows with formatting disc C,and then reinstalling all the games and software don’t resolve the problem.
    VirtualGamepad still works great with PS One emulator,so I guess the issue is the games don’t only recognize a virtual mouse.

    #26803

    PalmTime
    Keymaster

    Hmm, we don’t use a virtual hardware drivers… so that could be the issue. Are these games run by Steam in any way ? Just wondering. Did you do any update to the touch screen drivers ? changed an option in the touchpad settings ?

    #26854

    vodyanoy38
    Participant

    No,these are not run by Steam.Just old dvd versions,not requiring internet connection at all.
    Windows did some automatic updates,maybe touch screen drivers were updated as well,I don’t know.The issue can be in these updates?
    No,I did not change touchpad settings,I just played,exited the game,and next time I ran the game(with same settings),the virtual mouse were “disconnected”.
    Now I’ll try to re-install Windows and turn automatic updates off,maybe this would resolve the problem…

    #26879

    vodyanoy38
    Participant

    Reinstalling Windows and all the games with VirtualGamepad did not resolve the problem.I can start the game with buttons such as up,down and enter,and I can move in the game using Keyboard Control (WASD),but the mouse does not work,even L- and R-buttons.
    But(as I already said) if I run the game with a real hardware mouse connected,the virtual mouse begins to work until I exit from the game to Windows.I even don’t press or move the real mouse at all,it just must be connected when I launch the game until the game menu appears,once it appears,I can disconnect a hardware mouse,and play using only VirtualGamepad.
    Is there any way to emulate a hardware mouse so a tablet would think that a mouse is connected?

    #33795

    nech
    Participant

    Ive got the exsct same problem. Im trying to play TES Oblivion, and all the buttons on the gamepad work, apart from the mouse pointer. Ive also tried VirtualMousePointer, but the result is the same-game cursor stays in the center and windows mouse cursor works, but cant click anything. I tried plugging in a mouse, but it didnt change anything :/ any ideas?

    #34390

    PalmTime
    Keymaster

    Hi guys,

    So I do have the issue on one of my tablet but not the other… Which is strange in itself since they are the same product. This is, as of now, still out of my control, unfortunately. One way to resolve this might be to have a usb wireless dongle in the usb port… can somebody check since I no longer have one of those 😉

    Thanks

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.